Reply To: Setting up an old Egg-Bot with Ubuntu 18.04

Home Evil Mad Scientist Forums Egg-Bot Setting up an old Egg-Bot with Ubuntu 18.04 Reply To: Setting up an old Egg-Bot with Ubuntu 18.04

#27980
Participant

I think you guys did give me a good discount on the second pen arm parts when I ordered them a few years ago (you weren’t selling extra pen arm assemblies on your website back then, so I contacted you directly; I glossed over this in my post because I didn’t think it would be of general interest). No worries there. I got the Egg-Bot for Christmas a long, long time ago (found it in a cabinet recently and thought I’d try to finish putting it together), so I figured updating the firmware was a good idea. Not sure what version it is; the circuit board looks like the white one here: http://www.schmalzhaus.com/EBB/ , but doesn’t say v2.0, or any other version number, on it.

My attempts to create the correct Extensions directory with snap Inkscape failed repeatedly. I’d create it, and then couldn’t find it or transfer anything to it, either with the terminal or the file manager, after unhiding everything. I came across other users online with the same issue. I guess it’s a bug that not everyone experiences.

I think it’s possible Plotink didn’t install with the extensions–the Inkscape error message before I installed it was specifically mentioned ebb_serial.py. Either that, or ebb_serial.py didn’t work because PySerial was missing. The root of this problem might have been that I hadn’t installed pip on my laptop yet. Anyway, after installing (or maybe reinstalling) those three things, the error message went away.

I did get a USB permissions error with the firmware update the first time I tried to install it. It went away when I re-entered the command with sudo. That’s what gave me the idea that something similar might need to be done for Inkscape.

Anyhow, I am pleased to say it works now. It has scrawled HELLO WORLD in block letters on an old lightbulb (the only round thing I could find). Now I just have to learn to use Inkscape and figure out the calibration settings. =)