Re: avrdude problem with MEGA2560

Home Evil Mad Scientist Forums Microcontrollers avrdude problem with MEGA2560 Re: avrdude problem with MEGA2560

#22272
DavidCRobertson
Participant

Thanks again Windell.  We’re doing all the things you’re asking, and doing them on both platforms.

To be clear:  we’re taking a Mac (OSX 10.10.5) and uploading blink onto an Arduino Uno using a USB cable.  Works fine.  When we change the delay from 1000 to 100, you can clearly see that the new blink program is uploading successfully onto the Uno.
Then we do the same thing on the Arduino Micro.  Change the Arduino IDE settings, but same computer, same USB port, same result:  uploads fine.  Works fine.
When we switch to the Peggy2, update the Arduino IDE settings but same USB port, same computer, same port, etc., we get the error “stk500v2_ReceiveMessage(): timeout”.  Same with the SainSmart Mega2560 board.  Interestingly, when we try to upload the new blink program on the Duemilanove, it just hangs.  No error message.  
All the above is true when we do the same tests on Windows 10.
In both environments, we’ve uninstalled and reinstalled the Arduino IDE, we’ve installed the latest FTDI drivers, and we’ve tried with the original and the altered boards.txt file.
Thanks in advance for any help you can provide.
-D