Alpha Clock 5 problem: no separators

Home Evil Mad Scientist Forums Ask an Evil Mad Scientist Alpha Clock 5 problem: no separators

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #20236
    #ifdef moose


    I just finished building an Alpha Clock Five (blue, Rev D board). Everything seems to work, except that none of the dots on the LEDs light up. I assume that one of them is used to indicate whether the alarm is set, in addition to hh:mm separators. I ran the LED test, and all the linear segments of each display light up, but none of the dots do.
    Any suggestions of where I may have gone wrong?
    Windell Oskay

    Hi David,

      First off, this sounds like a hardware problem of some sort, since the decimal point LEDs should definitely light up in the LED test.  The decimal points are driven by pins 11 and 12 of the LED driver U3. Pin 12 is below and to the right of the “O” in “SDO” above U3.  Pin 11 is the pin to the right of that.  
    Pin 12 is connected to the upper-right pin of each LED digit on the circuit board (i.e., upper-left, if looking towards the front of the clock), and pin 11 is connected to the lower-left pin of each LED digit on the circuit board (i.e., lower-right, if looking towards the front of the clock).  Because these go in such different directions, it seems unlikely coincidence that anything could be wrong at both of those places.  That certainly suggests that the problem is at U3.  
    So, check to see if the IC is (was) fully inserted into the socket.  Also check to see if both pins 11 and 12 are properly soldered, and to see if there could be an accidental connection (solder bridge) between those points. You may need to remove the chip from the socket– very carefully! –in order to inspect the area under the socket, to see if there is a solder blob down there.
    If you have access to a multimeter, you might be able to use that as well, to see if those two pins are electrically connected to each other, and to the places where they are supposed to be connected. 
    #ifdef moose

    It’s working now.

    The IC seemed to be properly seated in the socket, so I pulled it and tested all the pins with a continuity tester, but there were no unintentional connections. I did observe two small blobs of solder underneath pins 12 and 13 on the socket side of the board, but they weren’t bridged. When I reinstalled the IC and rechecked it, the displays worked properly. I just needed to use a bigger hammer :-)
    Thanks for the pointers.
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.