Alpha Clock 5 Serial Comms

Home Evil Mad Scientist Forums Clock Kits Alpha Clock 5 Serial Comms

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20344
    IT_Sean
    Participant

    I’m trying to communicate with an Alpha Clock Five over a serial console.

    I am configured for 19200 / 8 / none and get a greeting when I connect:
    Hello, World.
    Alpha Clock Five here, reporting for duty!
    RTC not detected. I don’t know what time it is.  :(
    Setting the date to 2012. I didn’t exist in 1970.
    0:00:00 Sunday 1 Jan 2012
    However, I cannot seem to get it to respond to any commands.  I’m issuing A0HELLO [enter] which should, by my understanding cause the AC5 to display ‘HELLO’.
    Am i missing something here?
    • This topic was modified 2 years, 3 months ago by Windell Oskay.
    #21773
    Windell Oskay
    Keymaster

    From the docs, you need to send a full 12 bytes of data: “A0HELLO…..” to indicate both the text, and the decimals to display. 

    #21774
    IT_Sean
    Participant

    Windell,

    Thanks.  Tried that.  Still no response from the display.
    #21775
    Windell Oskay
    Keymaster

    If you haven’t yet been able to send a signal or reprogram the clock, it could be the case that there is a physical connection problem.

    You might consider trying to run our example code from within Processing.  That code is tested and works well, and should help to eliminate a connection problem as the issue.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.