Axidraw Coordinate Flip / Invert ?

Home Evil Mad Scientist Forums AxiDraw Axidraw Coordinate Flip / Invert ?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #29518
    CliffStoll
    Participant

    The image shown on my Inkscape display appears inverted when plotted with Axidraw.

    The Axidraw Home location corresponds to location x=0, y=11.5 (inches) on the Inkscape pages grid. Intuitively, I’d expect Axidraw home to be mapped onto Inkscape 0, 0

    Of course, this is a simple coordinate rotation – Within Inkscape, I can flip the entire image. Alas, but it’s confusing to edit images that are upside-down.

    Alternatively, I can rotate the Axidraw machine on my tabletop. Easy to do, but the back end of the writing arm hits a wall…

    Is there any option within the Axidraw cli to flip an image (not mirror) ?

    Thanx!
    -Cliff

    #29519
    Windell Oskay
    Keymaster

    I’m not certain that I fully understand the issue that you’re describing, but I suspect that it’s one of these three. If it *isn’t*, please say so, and help me understand exactly what the situation is.

    (1) In Inkscape’s Preferences, under the “Interface” heading, there’s an option: “Origin at upper left with y-axis pointing down”. If you check that (and restart Inkscape), the (0,0) corner of your document will be located in the upper-left corner of the page on your screen. This *only* changes the labeling of the on-screen coordinates and rulers; it does not affect the document or how it prints. However, it may help you to visualize the plot if the coordinates look reasonable to you.

    (2) You may be seeing the normal results of “auto-rotation”: see section 6.3 “Document orientation” in the AxiDraw user guide. Documents that are taller than they are wide are normally rotated, 90 degrees counterclockwise, when they are plotted, to reconcile the wider-than-tall plot area with portrait-mode artwork. You may prefer to disable this behavior and work only in landscape mode (or otherwise model the full plot area of the machine in your document).

    (3) You may be expecting auto-rotation, but in the other direction. If you’re expecting clockwise rotation but seeing counterclockwise, then it will feel like there’s an extra 180 degree rotation in there. There’s a hidden option in the axidraw_conf.py configuration file that you can use to rotate the other way: set auto_rotate_ccw to False. This file can be found in the Inkscape User Extensions folder — with the location visible in the Inkscape Preferences System heading. In the CLI, you can use a copy of this file with the --config option to specify that (and your other defaults).

    Finally, you might want to consider using Preview mode, with rendering enabled: It will show you the plan for how the machine will plot a given file, including how it travels from and to the home corner at the beginning and end of the plot. In many cases, this can help to resolve any ambiguities that you’re seeing. Preview mode is available both in Inkscape and the CLI.

    #29520
    CliffStoll
    Participant

    Sigh … after an hour of prodding, I’ve discovered Raspberrypi 4B is a 32 bit system.

    It appears that all Inkscape releases since 0.92 (2019) are for 64 bit systems.

    The Inkscape 0.92 Preferences for “Interface” doesn’t have origin selection. This was added in version 1.0

    Using old 0.92 version also explains why I’ve been confused using current documentation.

    #29521
    Windell Oskay
    Keymaster

    Is there any other effect of this, other than the on-screen rulers/coordinate display being inverted?

    #29522
    CliffStoll
    Participant

    Running Inkscape 1.1 on my iMac vs the 0.92 on the Raspberry pi.
    I’ve used the mac (with iPad-sidecar) to draw .svg images using Inkscape. Then transport the .svg to the Pi on a thumb drive, and the pi plots ’em on the Axidraw.

    So I’m flipping between 2 different revisions of Inkscape, as well as 2 operating systems. Lots of “That menu item doesn’t exist” and “That tool doesn’t seem to work here”. Dialogs are different. Lots of wasted time hunting for things.

    I think I may give up on the Pi, and find an old mac to run the Axidraw. Easier than juggling versions.

    • This reply was modified 2 weeks, 2 days ago by CliffStoll.
    #29524
    Windell Oskay
    Keymaster

    We’ve always recommended to preferentially use the CLI for plotting on the Pi and to try and avoid Inkscape there. Given that the differences are getting stark, I’ll start recommending that more strongly.

    It looks like the RPi hardware is 64-bit compatible, but the OS is lagging behind (see, e.g., https://forums.raspberrypi.com/viewtopic.php?f=117&t=275370 ).

    #29525
    Windell Oskay
    Keymaster

    Ah– you can run 64-bit Ubuntu on RPi 3 and 4: https://ubuntu.com/download/raspberry-pi

    That said, an old mac is an OK solution too. We’re currently supporting the latest Inkscape/AxiDraw software back to macOS 10.11; that will probably be changing to a minimum of 10.13 in the next major Inkscape update.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.