AxiDraw stopped working

Home Evil Mad Scientist Forums AxiDraw AxiDraw stopped working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28584
    Fabrice
    Participant

    I’ve been using it for 10+ days that I’ve had it. Was running without issues.
    Last night I unplugged it as I do at night (light and noise from it keep me up).

    When I tried starting a plot today in InkScape, I got this error message when trying to lower/raise the pen:

    Traceback (most recent call last):
    File “axidraw_control.py”, line 32, in <module>
    exit_status.run(e.affect)
    File “/Users/USERNAME/Library/Application Support/org.inkscape.Inkscape/config/inkscape/extensions/axidraw_deps/ink_extensions_utils/exit_status.py”, line 26, in run
    return func(*args, **kwargs)
    File “/Users/USERNAME/Library/Application Support/org.inkscape.Inkscape/config/inkscape/extensions/axidraw_deps/ink_extensions/inkex.py”, line 281, in affect
    self.parse()
    File “/Users/USERNAME/Library/Application Support/org.inkscape.Inkscape/config/inkscape/extensions/axidraw_deps/ink_extensions/inkex.py”, line 204, in parse
    self.document = etree.parse(stream, parser=p)
    File “src/lxml/etree.pyx”, line 3521, in lxml.etree.parse
    File “src/lxml/parser.pxi”, line 1880, in lxml.etree._parseDocument
    File “src/lxml/parser.pxi”, line 1900, in lxml.etree._parseFilelikeDocument
    File “src/lxml/parser.pxi”, line 1795, in lxml.etree._parseDocFromFilelike
    File “src/lxml/parser.pxi”, line 1201, in lxml.etree._BaseParser._parseDocFromFilelike
    File “src/lxml/parser.pxi”, line 615, in lxml.etree._ParserContext._handleParseResultDoc
    File “src/lxml/parser.pxi”, line 725, in lxml.etree._handleParseResult
    File “src/lxml/parser.pxi”, line 654, in lxml.etree._raiseParseError
    File “/var/folders/1l/j055bf6s6sgglzrstxmt08t40000gn/T/ink_ext_XXXXXX.svgS8HJR0”, line 3
    lxml.etree.XMLSyntaxError: xmlns:ns: ‘&#38;#38;ns_ai;’ is not a valid URI, line 3, column 38

    The error stays even after restarting the computer, reinstalling the axidraw controls in inkscape, and changing USB ports.
    Please help me with this urgently! Thanks

    • This topic was modified 4 weeks, 1 day ago by Fabrice.
    #28586
    Windell Oskay
    Keymaster

    Since you also emailed us with the same issue, I’ll follow up there.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.