Bulbdial Clock – Trouble with Red LEDs

Home Evil Mad Scientist Forums Clock Kits Bulbdial Clock – Trouble with Red LEDs

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #20219

    Just finished building the Bulbdial clock, and everything checked out perfectly until literally the last two LEDs.  Using the “Adjust” mode, all of the blue LEDs work correctly, and all of the green LEDs work correctly.  When checking the red LEDs, however, the last two (the ones at the 4 & 5 o’clock position – which should project 10 & 11 o’clock) do not light.  Instead a combination of blue and red LEDs light.  When the 4 o’clock position red LED should be lit, five red LEDs (at the 11, 12, 3, 7 and 8 o’clock positions) and five blue LEDs (at position 26, 27, 28, 29 & 30 – when starting with the topmost LED as 1 and counting clockwise) are lit.  When the 5 o’clock position red LED should be lit, five red LEDs (at the 1, 2, 6, 9 & 10 o’clock positions) and five blue LEDs (at postions 5, 10, 15, 20 & 25 – when starting with the topmost LED as 1 and counting clockwise) are lit.

    I’ve visually inspected the boards and all of the solder joints look good.  I’ve checked the orientation of the two problem red LEDs, and they appear the same as the 10 red LEDs that work correctly (i.e. flat end faces same way).  Any hints on how I can troubleshoot this?
    Windell Oskay

    Those two LEDs are D610 and D106, which are connected between control lines LED6 and LED10.  The LED10 connection to the red ring is good, because the rest of the red LEDs– all of which are also connected to LED10 –are working, so the problem must either be at the LED6 control line, or is at one or both of those red LEDs.

    When these LEDs cannot light up, the current that would normally go through them needs to go *somewhere,* and so it goes through the other red and blue LEDs connected to lines LED6 and LED10– which are just the ones that you listed on the red and blue rings. 
    Check the soldering first at vertical wire jumper LED6, at the red ring.  This is the most likely place where the trouble could be.  Also check the traces that lead from that point to the two red LEDs that are not lighting.     

    Thanks.  The problem was at LED6 where it connects to the blue circuit board.  For some reason, the solder was not adhering to the pad on the blue circuit board.  I removed the solder and cleaned the pad and re-soldered.  That solved the problem.


    I just wanted to add a note to this thread, since it helped me quickly track down the problem in my own kit’s assembly. Diagnostic steps guided by the above very helpful info from Windell include:

    1. Two red LEDs fail to light properly; when they are supposed to light up, seemingly random other LEDs on all rings light instead. See “the current that would normally go through them needs to go *somewhere,*”.
    2. Using the diode test setting on my multimeter, worked my way back from the LED itself (either one of the pair that didn’t work) until I found a point on the circuit where the LED didn’t light up when probed.
    3. Looked more carefully at the solder joint just past the probe point in the direction of the LED (the point at which the 0 ohm jumper connects to the red PCB), found that it had been done poorly, with the jumper lead still mobile in the through-hole of the PCB.

    Redid that solder point, and voila, the clock works perfectly!

    By the way, thanks so much for doing such a great job with this kit. The instructions were awesome, incredibly easy to follow, with plenty of good photos and important tips that made everything so simple to do. And of course, the clock is a real treat itself once assembled.

    One minor suggestion: the instructions I got seemed a little out of date with respect to the Chronodot, in that those instructions described a tabbed battery that had to be soldered into place, and headers that had to be soldered to the Chronodot board, while the part I got was much easier: it had a regular slide-in battery holder already soldered to the board, and the headers were already soldered as well. If these welcome improvements to the kit are going to be standard issue going forward, it might be a good idea to update the instructions to match. I didn’t find it that confusing, and I suppose most people wouldn’t, but you never know. It was a notable contrast to the rest of the instructions which are so good at providing every little detail needed to assemble the kit successfully.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.