Bulbdial LED Shadow Issues

Home Evil Mad Scientist Forums Clock Kits Bulbdial LED Shadow Issues

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26867
    JMP0
    Participant

    Have assembled six (6) Bulbdials over perhaps five (5) years.
    All went easily and turned out very well.
    (BTW, I must say that your assembly instructions are excellent!)
    But the last one, purchased last year (late 2017) has major problems with
    shadows from the LEDS on the dial face, both front and rear projection.
    It seems that they were specified with a wider angle variation for some reason.
    Do I need to re-order ALL the LEDs at an extra cost???
    Replacing them all will be a major PITA and will not look nice.
    Have tried aligning (over and over) as well as adjusting individual levels
    of the rings does not help.

    Any suggestions are most appreciated.

    #26868
    Lenore Edman
    Keymaster

    We haven’t changed LED vendors and we normally make sure that all the LEDs are from the same batch for these kits, which normally means they’re pretty consistent. Are all three rings affected, or just one color? Would you mind posting or emailing a picture of the problem?

    #26874
    JMP0
    Participant

    Hello Lenore,

    Kurt here.
    Thank you for your response.
    Yes, all three rings are affected.
    Would like to attach a picture but cannot figure out how to do that here.

    #26875
    JMP0
    Participant

    Have posted a picture
    https://imgur.com/a/VeZeAFU
    But seems to be unavailable unless registered and logged on…

    #26876
    Lenore Edman
    Keymaster

    Would you mind also taking a picture of it not in the dark, from the front as well as from the side? It’s hard to see the shape of things without any light on the PCBs.

    #26880
    JMP0
    Participant

    Yes, I WOULD mind, as the picture which I posted clearly shows the problem.
    Note this post from another dissatisfied user:

    file:///K:/Manuals/BulbDial/Topic%20%20Bulbdial%20clock%20%E2%80%93%20Thoughts%20on%20build%20and%20question%20on%20shadows%20%20%20Evil%20Mad%20Scientist%20Laboratories.html

    Obviously there has been a problem before, and it has shown up again.
    Quality control is obviously an issue.
    I will be ordering the replacement LEDs from Mouser at my own cost.
    Plus spending my time to replace them at twice the hours.

    Thank you for your lack of customer satisfaction

    I will not be purchasing from EMS in the future.

    #26883
    Lenore Edman
    Keymaster

    As we mention in that post you referenced, we switched to wider angle LEDs for a short while in 2013. We switched back to the original LEDs and have been using them ever since. There is some amount of variation in them, but within expectations.

    I asked for additional pictures because I don’t fully understand what is going on with your kit. The width of the lit-up areas is similar between all three colors as we would expect. I was hoping to get additional information that would help me diagnose the problem.

    I will help you to resolve the problem and am happy to provide replacement parts as needed. I need for you to help me to understand the problem both so that I can help resolve your specific instance but also to look for wider problems that could affect other kits.

    If you would prefer to reach out via email, you can use the contact form.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.