BulbDial Red Hour LEDs Problem (Solved)

Home Evil Mad Scientist Forums Clock Kits BulbDial Red Hour LEDs Problem (Solved)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #20147

    After building my first BulbDial clock with zero problems about a year ago, several people have showed and interest in having one.
    Ordered two more and they both have the same problem with the red LEDs.
    The blue and green rings work fine.
    The red ring shows this progression while single stepping:
    12 – 1
    10 – 11
    8 – 9
    6 – 7
    4 – 5
    2 -3
    Have been troubleshooting it over and over, ohming out connections, visual inspection, checking with the diode function on a multimeter, etc. with no luck.
    First found out that the red LEDs were manufactured reversed with regards to the flat / long lead / large metal piece inside did not match the other LEDs.  When assembled, no LEDs were active.  After reversing the polarity, the above pattern appeared.
    Have not checked the software yet as I do not have a cable or the Arduino software yet.

    Any ideas would be greatly appreciated!

    Windell Oskay

    I’m sorry to hear about the trouble.

    We’re currently using really nice Cree brand red LEDs in our RGB Bulbdial Clock kits, and we have (at least until now) always found them to be of exceptionally quality and consistent in all of their important properties, including orientation.  
    We have checked the remaining LEDs that we have in stock– which we believe are from the same batch –and they appear to be correctly, and consistently manufactured.  It seems *extremely unlikely* to us that there could be a manufacturing error of that magnitude that would affect only part of the batch, especially from this brand.  
    The Bulbdial assembly instructions indicate a very specific way to identify the polarity of each LED in the kit: to look at which lead is longer, and our LED bending jig is specifically labeled that you should use it this way.   The flat is also a generally reliable indicator of polarity. However, the internal leadframe shape is *not* a reliable indicator, and is indeed different between the red LEDs and the blue/green LEDs.    
    The pattern that you are seeing is also consistent with having the red LEDs installed backwards; the classic sign of a backwards ring is that they light up in pairs.   So, as a first step, you need to fix that issue.   
    Then, you’re back to the initial problem, which is that the LEDs weren’t lighting at all.  There is likely some other soldering issue that is causing this problem.  The most likely cause of this kind of problem is a bad connection somewhere between the microcontroller and signal line LED10.  It turns out that the most *common* cause of this exact problem is that people forget to install R10– any chance you skipped that step on your faster trip through the instructions on this round?   If it is there, double-check the soldering at resistor R10, on the vertical jumper LED10, and on the corner pin of the microcontroller, close to D15.

    Thank you for your swift reply.
    Reversed polarity on one red ring and that did the trick.
    The reversed lead frame threw me for a loop, actually the opposite of the first working BulbDial.
    Have a beer on me for pointing me in the right direction ;=}

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.