Can’t render Hershey fonts

Home Evil Mad Scientist Forums AxiDraw Can’t render Hershey fonts

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #29229
    Tirki
    Participant

    Under Axidraw utilities when I try to render text or a font table I get the following error:

    Usage: hershey.py [options] SVGfile

    hershey.py: error: no such option: –otherfont

    Anyone have any suggestions?

    #29230
    Tirki
    Participant

    Update I am using Inkscape .92

    #29231
    Windell Oskay
    Keymaster

    Try the Hershey Text in the Text (or possibly Render) submenu in Extensions.

    #29232
    Tirki
    Participant

    Same error dialog.

    I have tried ‘Extensions/Axidraw/Axidraw utilities/hershey text’ and ‘Extensions/Text/Hershey Text’. Same error if I try to convert text to Hershey text or generate a font table.

    It feels like a path error (Ubuntu 20.4) but I haven’t found it yet.

    Thanks for all your help!

    #29233
    Windell Oskay
    Keymaster

    Maybe consider updating to the current software version?

    #29234
    Tirki
    Participant

    The current version of which software. I think hershey.py is current.

    You did great comments in your code. Here is the time stamp:
    Hershey Text 3.0.1, 2019-07-05

    #29235
    Windell Oskay
    Keymaster

    I’d suggest one of the following:

    * Try a fresh install of Inkscape, and *do not* install the AxiDraw software, if you want to use the Hershey Text that’s included with Inkscape.

    * Update to the current version of Inkscape (1.1) and install the current Axidraw software.

    #29247
    Tirki
    Participant

    Done and done with no change in behaviour.

    I think I will just tinker with it until I get it sorted out. I really do not want to burn your time with something so trivial.

    If I get it fixed, I will post here.

    Thanks!

    #29248
    Windell Oskay
    Keymaster

    If you actually uninstalled the AxiDraw software, then there would not be a Hershey Text visible under AxiDraw Utilities, so it’s hard to believe that there would be “no change in behavior.”

    #29249
    Tirki
    Participant

    I did ‘apt-get purge inkscape’ thinking that would do it. I suspect that did not remove all the inkscape directories. I will hunt them donw and remove them.

    Thanks!

    #29250
    Windell Oskay
    Keymaster

    Check your user extensions directory — you can find its location in Preferences, in the System panel.

    The issue certainly seems to be that you aren’t running a version of Hershey Text that’s compatible with your version of Inkscape — it should be possible to track down how that’s possible.

    #29251
    Tirki
    Participant

    Just deleted the extension directory and I am back to the old Inkscape behaviour.

    I prefer the Axidraw Inkscape extensions so I will tinker with that.

    Thanks for the tip on the extensions directory. I can take it from here.

    Cheers!

    #29252
    Windell Oskay
    Keymaster

    If you’d like the current version, then please do update to the current version, which works with Inkscape 1.0+.

    #29253
    Tirki
    Participant

    OK, all better now. My PPA was installing Inkscape .92. I purged that and the Inkscape extensions directory then did the snap install of Inkscape 1.1. That worked like a champ.

    I installed your Axidraw extension in the Inkscape extensions directory and everything works now.

    I appreciate all the time you put into this.

    Cheers!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.