"Failed to connect to AxiDraw"

Home Evil Mad Scientist Forums AxiDraw "Failed to connect to AxiDraw"

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25604
    f1matthes
    Participant

    Today I received my new AxiDraw V3/A3.
    I am using Windows 10.German langauge.
    I installed Inkscape 0.91 Windows 64 MSI I (Complete) without error.
    I installed AxiDraw_178.exe without error message.
    I started InkScape.
    AxiDraw is displayed under extensions. (correct version)
    I connected AxiDraw to the power outlet (with an US adapter).
    I connected the USB cable with my computer.
    (I get no “USB connected” sound, no movement of AxiDraw, no light indicator at this point)
    If I try to use the AxiDraw Control to set the AxiDraw Model (V3/AD) or to send the raise pen / turn off motors command, I get the error message

    “Failed to connect to AxiDraw”

    I checked your forum entries to solve the problem and tried the following:
    I deinstalled Inkscape, manually removed the remaining subfolders. Restarted the computer and reinstalled Inkscape 0.91 64bit an the AxiDraw software.

    I measured the voltage of the power cord and get 9.3V
    I am able to successfully connect to other USB devices using the USB cable shipped with AxiDraw.
    The 3-Pin Connector for the stepping motor lifting the pen is correctly connected.

    After a while the “round thing next to the power connector gets warm/hot. This is the only observable behavior on the side of the AxiDraw (no light, no movement.

    There are no error messages or yellow icons in the device manager of Windows 10.
    I have installed the latest Windows 10 Version and all available BIOS updates.

    I think there might be a hardware problem with the device I received.
    Please advise how to proceed.
    Thank you for your support.

    #25605
    Windell Oskay
    Keymaster

    I’m sorry to hear about the trouble.

    Unless there is physical damage from shipping, this set of symptoms most usually indicates that the USB driver may have failed to install correctly.

    Please download and try running this installer:
    https://github.com/evil-mad/EggBot/releases/download/2.7.1/UBWDriverInstaller_v20.exe

    Please grant the installer permission if it asks, and pay special attention to whether any error messages are generated. Once you have done so, see if you can establish communication to the machine.

    #25606
    f1matthes
    Participant

    I started the Installer v2 and confirmed the security alert (accept changes).
    The installer proposed to install here:

    C:\Program Files (x86)\Inkscape\share\extensions\UBWDriverInstaller

    Since I use the 64bit Version of Inkscape 0.91 (as recommened by the online AxiDraw V3 installation instructions), I changed the folder to.

    C:\Program Files\Inkscape\share\extensions\UBWDriverInstaller

    I did not have to confirm any Admin Rights / Missing Driver Signature dialog and I did not get any other dialog messages.
    I looked at the install log (green on black background) and everything worked fine. No error messages.

    I then connected AxiDraw to the power outlet and then connected AxiDraw via USB cable.
    Again, nothing happened (no “USB device connected sound”, no blinking, no movement, no sound of AxiDraw).

    If I started Inkscape, and tied to query the version or raise the pen and stop the motors, I still got the error message

    Failed to connect to AxiDraw

    The AxiDdraw Control displayed Version v.1.7.8 2018-04-22.

    I then opened the directory
    C:\Program Files\Inkscape\share\extensions\UBWDriverInstaller
    in the Windows explorer and manually started
    USBDriverInstaller.exe
    I had to confirm that I want to perform changes on my machine, which I did.

    A window opened where I clicked the “Install Drivers” button.
    I did not get any error dialog message and the following information was displayed

    Starting driver installation. Please wait …
    Complete: Driver was pre-installed to the driver store successfully.
    Note: If the Found New Hardware Wizard appears upon plugging in
    the device, allow Windows to search automatically for the driver.

    I then unplugged the USB cable and re-inserted it.
    Nothing happened (no USB device connected sound).
    I restarted Inkscape and was still unable to connect.

    I unplugged AxiDraw (USB and power).
    I restarted the computer.
    I connected AxiDraw (first power, then USB).

    I am still unable to connect.

    There is no light, sound or movement of AxiDraw. The round thing next to the power supply plug gets a little bit warm, but that’s it.

    Please advise how to proceed.

    I bought the device here: http://www.robotshop.com (France).
    The serial number of my device is S/N: A3-0078

    Best regards,
    Florian

    #25607
    Lenore Edman
    Keymaster

    When you have just the USB cable plugged into the AxiDraw (please make sure that the power supply is NOT plugged in) does the LED labeled USB next to the power jack turn on? There is also an LED above the capacitor cutout labeled 3.3V. Does it turn on? (You may need to look upward through the cutout to see it.)

    Are there any signs of damage from shipping, such as bent parts or loose connectors?

    #25620
    f1matthes
    Participant

    (I was on a business trip and could not check the device earlier)
    I can see the faint green LED light above the capacitor if I connect AxiDraw by USB cable only.

    I took two “unboxing” pictures and the package only had a small bump at one edge. Inside the box and on the AxiDraw itself there is/was no damage.

    I attache a link to a folder with three pictures for your information.

    https://drive.google.com/open?id=1K1XPo6_aFkBnorY0Smd2_GZdUWB6B8n3

    What else should I do to use the device or get a replacement?

    Thank you for your support
    Florian Matthes

    #25621
    Lenore Edman
    Keymaster

    Would you follow up with us by email so that we can send you a replacement controller board? I will also have some other tests for you to check if there is any other damage.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.