Help with servo motor not working

Home Evil Mad Scientist Forums AxiDraw Help with servo motor not working

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #30288

    I am having problems with my Axidraw V3/A3. After two months of not using it I tried today to draw something but the servo motor for the pen was not working (no movement) . I knew that this could fail that is why i bought beforehand another two motors. I change the motor and still it was not working. I have read in the forum all the cases just to see if i can fix my problem but i haven’t bee lucky yet. Until now i have tried the following:

    I tried all the different USB cables that i have around me
    I tried every single USB port in my computer
    I tried changing the pen to position 60 Max 40 Min
    I tried With Inskape in Mac and Linux versions
    I tried connecting the motor directly in the EBB (to see if there was a problem with the cable)
    I tried moving the cables to see if there was a loose cable
    I tried all three servo motors
    I updated also the firmware

    I have tried dozens of times the toggle up/down and the cycle pen down/up options and once the motor moved a little bit and three times there was like a click rattle inside the servo motor. But the rest of the time not a single sight of movement or noise.

    I have a voltmeter but i don’t know if can can break the axidraw even more just messing around with it.

    Any help will be great!!
    Thanks in advance

    Windell Oskay

    Is XY (horizontal) motion working correctly?


    Yes XY works without problems

    Windell Oskay

    Then there’s no reason to suspect an issue with:
    * Your USB cables
    * Your USB ports
    * Which platform you are using (Mac/Linux…)
    * Your firmware

    Until the problem is resolved, I’d recommend testing the servo motors plugged in directly to the EBB (control board), to eliminate the vertical slide and the servo cabling as possible issues.

    Check for any signs of damage — bent pins, anything loose or broken — around the EBB.

    Set your pen range to 0, 100, and try cycle mode with a servo motor connected directly to the EBB.

    If you’re still not seeing anything, let’s try using a different pin on the EBB.

    A. Open Inkscape
    B. From the menu, select Inkscape > Preferences (on a Mac) or Edit > Preferences (Linux)
    C. Select System from the list on the left panel of the preferences window.
    D. On the right-hand panel is a list of folder locations. Click the “Open” button to the right of the “User extensions” folder location. This will open the extensions folder on your computer.

    In that folder, find, and open it in a plain text editor.
    In that file, find where it says servo_pin = 1 and change it to servo_pin = 2 and save the file.

    Then, try connecting your servo motors **two** positions above the normal servo position, and see if that works.


    I checked all the pins with a loupe and the bottoms ones where a little bit bend, still they seem to be in position without any kind of movement or broken.The rest seems to be fine. I changed the file “” in linux as you mentioned. And i tried the cycle mode with out success in all the servo motors. Nothing moves. I reseted the computer and nothing changed. Then i try to modify the file “” in Mac but oddly i couldn’t find that option in the file they seemed to be quite different.

    Windell Oskay

    Near the top of, what version number is listed there?


    In the linux version i have 3.6.0

    In Mac i have 2.7.0

    Windell Oskay

    You should consider updating the mac to the current version; this feature was added in version 3.5.


    I just updated the Mac version and changed the servo_pin to 2. Again I tried with the 3 servo motors and no movement at all.

    Windell Oskay

    Did you test these three motors on the set of three pins *two positions* above the normal servo position, and with the brown wire towards the back of the AxiDraw?


    Yes I tried them in the right position. I also checked a picture of the EBB with the pin names just to be super sure. I also checked the correct position of the colors
    Brown = Ground
    Red = 5V
    Orange = PWM Signal

    Windell Oskay

    Can you please verify that you are using the original power supply without any kind of voltage adapter?


    Yes i just checked it and it is the original and there is not any kind of voltage adapter

    Windell Oskay

    I can’t immediately think of any situation where XY motion would work correctly but pen lift would not (in the way that you describe here) except:

    * If the pen-up and pen-down heights were the same (or very close)
    * Not connecting to the correct set of pins on the EBB for the currently saved servo_pin setting

    * All three servo motors are malfunctioning or
    * Both servo output pins on the EBB are malfunctioning
    * The 5 V power supply on the EBB is malfunctioning

    So, double check that XY motion is still working and that you still have a good range set on the servo positions.

    Check with the multimeter to see if there really is 5 V on the center pin versus the back pin, using the third set up (alternate servo position).

    If those things are all OK, then it seems likely that either all three servos are malfunctioning or the EBB itself is malfunctioning– though both require multiple things to go wrong.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.