Inkscape Extension for Axidraw on Raspberry Pi

Home Evil Mad Scientist Forums AxiDraw Inkscape Extension for Axidraw on Raspberry Pi

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29508
    CliffStoll
    Participant

    Minor problem getting Inkscape to drive Axidraw from a raspberry pi.

    Axidraw extension configuration tab throws this error:
    …must be run with Python 3.6 or greater

    As of 2021, the Raspberry Pi has both Python 2.7 and 3.7.3 installed:
    <python> defaults to python 2.7
    <python3> defaults to python 3.7.3

    so a simple redirect works:
    sudo mv /usr/bin/python /usr/bin/OLDpython
    sudo ln -s /usr/bin/python3 /usr/bin/python

    now, python -V
    shows Python 3.7.3

    and the Axidraw Extension works properly.

    #29509
    Windell Oskay
    Keymaster

    Good tip!
    It’s also possible to redirect Inkscape itself to use a different python version: https://wiki.inkscape.org/wiki/Extension_Interpreters#Selecting_a_specific_interpreter_version_.28via_preferences_file.29

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.