Path order not mirroring file path order in Inkscape?

Home Evil Mad Scientist Forums AxiDraw Path order not mirroring file path order in Inkscape?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29939
    Liz
    Participant

    I thought that the path print order was supposed to be the path stacking order (in Object and Layers panel) in the SVG file.

    I have an SVG file that I can’t get to print in that order. I have the “None” option on plot optimization selected and have tried quite a few many things and still can’t get it to work.

    Any ideas?

    Thanks!

    #29940
    Windell Oskay
    Keymaster

    As I said on reddit, in *most* cases, plots with “preserve file order” do exactly follow the file order.

    However, as it says in the user guide:

    > One exception to note is that if one path ends right where another begins (on the same layer), those paths will be joined together, reducing the number of pen lifts needed.

    (There is a hidden feature that can disable this optimization.)

    If that’s not the situation, and you think that the software is not following the document order, then something else is wrong. To look into it further, please either provide a method that we can use to reproduce the issue or an SVG file that shows the issue. I’d recommend contacting support through email or our support discord for those, as the forums don’t support file attachments.

    You can also preview plot order with the preview mode.

    #29941
    Liz
    Participant

    I have tried a few things, and I think actually as you say that my file holds the exception: a few paths end where the other begins. If I space certain items out it fixes the problem. I don’t know why I didn’t understand that immediately.

    But anyways, where is the hidden feature to disable this optimization?

    I’d like to disable it and try again.

    Thanks!

    #29942
    Windell Oskay
    Keymaster

    The option is in the axidraw_conf.py configuration file.

    From Inkscape, you can locate this file as follows:

    A. Open Inkscape
    B. From the menu, select **Inkscape > Preferences** (on a Mac) or **Edit > Preferences** (if using Windows)
    C. Select System from the list on the left panel of the preferences window.
    D. On the right-hand panel is a list of folder locations. Click the “Open” button to the right of the “User extensions” folder location. This will open the extensions folder on your computer.

    In that folder, locate axidraw_conf.py (likely the first item) and open it in a plain text editor. There, locate the line:
    min_gap = 0.008
    and change that value to zero or a negative number. Then, save the file.

    #29944
    Liz
    Participant

    SOLVED!

    amazing. thank you.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.