Pen came up on its own while drawing

Home Evil Mad Scientist Forums AxiDraw Pen came up on its own while drawing

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
  • #27963

    I was trying to print a large plot (10mb .svg)

    After a few hours of plotting, the pen went to “pen up” position while the axidraw continued to plot. (It appeared to be plotting correctly.)

    I couldn’t think of a way to get the pen down while it was drawing, so cancelled the plot.

    Axidraw is connected to a Raspberry Pi 3.

    I sent the file to the Pi from another computer via scp.

    I started the plot remotely via the command line interface.

    Something I could have done differently to insure that my plot would finish?


    Windell Oskay

    Is this an issue with the pen motor not functioning, or something else?


    I think the motor / servo is OK.

    The axidraw was going along fine and raised the pen on its own while continuing to draw.

    Windell Oskay

    I am not aware of any process by which the servo can become unresponsive as a result of the program that you are running. If XY are responsive, then the Z should be responsive as well.

    Here are a few things to consider:

    * If the motor still moves but the the vertical slide is sticky, that can sometimes result in the pen not falling when it is supposed to. (It cannot explain the pen raising on its own, though.) Make sure that you’re not overtightening the thumbscrew, and check that the vertical slide falls freely.

    * If the servo were to lose its physical connection to the control board, it could easily result in this behavior. Carefully check that the servo connector cable on the left side of the base is fully and securely in place. If you have swapped out a servo on your own, check also that the connection of the servo to its extension cable is secure and that the connection point is held securely in place with the cable ties. You might also try wiggling the cable in different places to see if something seems loose or intermittent.

    * If you are plotting something with thousands of very short paths, that can be stressful on the pen-lift servo. One of the failure modes of servo motors is that they can become unresponsive when overheated. If you see this kind of thing again, feel the servo motor, to see if it’s overheating. If you do have plots like this, you can help to reduce the stress on the motor (and increase the speed of your plot) by reducing the total pen-up/pen-down travel distance to only as much as is needed.

    * If you are plotting something with no pen-lift movement, but instead very long periods of constant pen-height movement (which sounds like it may be the case), one possible concern is that in recent versions of the EBB, the firmware turns off power to the servo after some period of inactivity. These recent versions are distinguished by having a “micro-B” usb connector rather than a “mini-B” usb connector. This normally happens invisibly, without effect. I have not observed nor heard of any cases where the servo raised position as it was powered down, but that is not outside the realm of possibility. If your EBB firmware is v 2.6.0-2.6.2, then the default timeout is 15 minutes. Any Z movement command would reset the timer, and power would not be restored until another Z command was issued. So, if you are doing individual pen-down paths much longer than 15 minutes, please say so, and I can help you modify the software to alter this timeout.


    1) I don’t think it’s a sticky vertical slide, but I’ve changed to a somewhat heavier mechanical pencil.

    2) I don’t see any loose wires.

    3) Maybe a million tiny squiggles, so overheating could be a culprit.

    4) Lots of pen lifts. Lots and lots, so not that timeout anyway.

    Back to the drawing board….

    Windell Oskay

    Well, please keep me posted if you learn anything new. I would definitely like to get to the bottom of this.


    It’s printing now.

    I’ll let it run overnight and see how it looks in the morning.


    Hey, maybe it is the timeout.

    The thing has been plotting for a while now and I noticed that while it’s making lots of little squiggles, it’s not lifting the pen between them.

    Also, the servo motor is cool to the touch.


    Oh, it looks like my fault.

    The paper isn’t flat, so the pen prints on the high part and misses the low part. (But the servo looks like it’s “up”.)

    The difference between “high” and “low” is very small, but just enough that the pen clears the paper in the low part.

    Because the plot is lots of small marks close together, the pen stays in the sme area for a long time, so I didn’t realize what was happening.

    I think that’s the answer.

    I’ll try the plot again with properly thick and smooth paper and expect it will be fine.

    It’s easier to see that the pen doesn’t touch the paper than to see that the paper is wavy.

    Mea Culpa

    Windell Oskay

    If the squiggles touch end to end such that there are not supposed to be any pen lifts, then yes, the timeout could be a factor.

    Here is how to edit the timeout setting. Download a fresh copy of the CLI API, and open pyaxidraw/ in a text editor. (You can do this right on the Pi if you like.)

    Find the line that says def queryEBBVoltage

    On the line before that, add the following line:

    ebb_serial.command(self.serial_port, 'SR,0,1\r')

    Take care that the indentation should match the line above it.

    This will disable the servo power timeout. You can also set it back to short,

    ebb_serial.command(self.serial_port, 'SR,60000,1\r') will set it to one minute, or

    ebb_serial.command(self.serial_port, 'SR,43200000,1\r') should set the timeout to 43,200,000 ms, or 12 hours.

    After making the change to that file, use pip install . as usual to install the software. You do not need to remove prior versions before installing the new one on top of it.

    Windell Oskay

    I see an update after I finished testing the code. ;)

    In any case, I hope that your fix is the easier one. Sometimes adding a little *more* Z range, or shimming the paper or AxiDraw feet is the right answer.



    Magnifying glass shows a continuous line of joined circles kind of like cursive script, so timeout may be a factor, along with non-flat paper.


    Well, the offending plot printed today in something like seven hours.

    So, I assume it was not a timeout problem.

    That pretty much leaves the warped paper, but also the fact that I switched from plotting from Inkscape to using the command line interface.

    I’m reasonably sure that the pen up and pen down positions, as well as a few other relevant settings, are not the same when I send the plot from the CLI as they are when sending from Inkscape.

    That, combined with the paper issues, left the pen off the paper for part of the plot.

    Windell Oskay

    The CLI and Inkscape use independent sets of parameters. If you’re using the same version (2.5.x) in each, then the values are set the same way, but you would need to set them.

    If it might be paper/machine flatness, I would suggest that you test your pen up/pen down positions in the four corners of the plot area as well as the center (for example, on top of a thin piece of plastic or paper that will not bleed through) to ensure that you have the required range.


    Thanks That’s what I figured was happening.

    I wasn’t sure if I should start a new thread for the pen up / pen down stuff:

    I can’t control the pen up / pen down from the cli using raspian on a raspberry pi.

    “Axidraw -M pen_up” requests a filename in order to work, but when I include a filename, it tries to plot the file (as you might expect). Same with pen down. I just want to adjust the pen height without moving the pen from home position.

    I suppose I can install Inkscape and axidraw extensions on the pi and adjust from there, but that has its own set of self inflicted problems:
    I won’t muddy the waters with those issues here.

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.