Problem uploading v2 firmware to first-gen Alpha Five Clock

Home Evil Mad Scientist Forums Clock Kits Problem uploading v2 firmware to first-gen Alpha Five Clock

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #20124

    I love my alpha 5 clock. I was excited to read about the new v2 firmware and so I decided to try to update my clock tonight. Unfortunately it’s not working. The same set-up with arduino 023 worked for me with the previous firmware, so I’m not sure what’s wrong.

    Here’s what I did. After downloading the libraries and sketches installed on my mac (described at, I was able to compile the Alhpa_20_ino sketch with Arduino 1.01 without errors. I connected to my clock using the FTDI cable (TTL-232R-5.0V), set the hardware board to “Sanguino W/ ATmega 644P” and the serial device to cu.usbserial-FTExxxxx (tried tty.usbserial also). But when I upload I get the following error:

    Binary sketch size: 50,300 bytes (of a 63,488 byte maximum)
    /Applications/ -C/Applications/ -v -v -v -v -patmega644p -cstk500v1 -P/dev/cu.usbserial-FTE3QCK3 -b57600 -D -Uflash:w:/var/folders/zk/9qdrm6y50n738x_hjf10hy6m0000gp/T/build4079987468705148959.tmp/Alpha_20_ino.cpp.hex:i 

    avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
             Copyright (c) 2000-2005 Brian Dean,
             Copyright (c) 2007-2009 Joerg Wunsch

             System wide configuration file is “/Applications/”
             User configuration file is “/Users/foz/.avrduderc”
             User configuration file does not exist or is not a regular file, skipping

             Using Port                    : /dev/cu.usbserial-FTE3QCK3
             Using Programmer              : stk500v1
             Overriding Baud Rate          : 57600
    avrdude: Send: 0 [30]   [20] 
    avrdude: Send: 0 [30]   [20] 
    avrdude: Send: 0 [30]   [20] 
    avrdude: ser_recv(): programmer is not responding
    avrdude: stk500_recv(): programmer is not responding

    avrdude done.  Thank you

    Once uploading begins, the clock goes dark, restarts, and then displays the time as usual. The upload failure is reported a few seconds later in the Arduino IDE. 
    Any ideas? Is there some hardware difference between the new/old Alpha Clock Five that might prevent me from using the latest firmware?
    Windell Oskay

    There is indeed a software issue that can prevent this from working.  The bootloader that shipped on kits with on Alpha Clock Five firmware v. 1.0 had a programming rate of 38400 baud, while the default bootloader baud rate for version 2.0 is 57600. (This rate is the default for the new version of Sanguino that we are using.)   

    Since the bootloader baud rate can *only* be changed through an ISP programmer, you need to reconfigure your Arduino installation to upload firmware at 38400 baud, rather than 57600.   Instructions on how to do this are a little further down on our page about the version 2.0 firmware: 



    there is a typing error on the wiki page:

    In that file, locate the line that reads
    “atmega644.upload.speed=57600”, change it to read
    “atmega644.upload.speed=34800“, and save the file.



    Windell Oskay

    Thanks– fixed!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.