Servo – Pen Raise & Lowering doesn’t work in Manual mode

Home Evil Mad Scientist Forums Egg-Bot Servo – Pen Raise & Lowering doesn’t work in Manual mode

  • This topic has 4 replies, 3 voices, and was last updated 8 years ago by Shel.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #20526

    I just assembled a brand new eggbot deluxe from Sparkfun (Chassis v2.0) and I’m attempting to calibrate and perform a hello world print.  Everything seems to be working OK with the exception of the servo.

    I was able to get the pen raise and lower % set and calibrated using “toggle pen up/down”, however the “raise pen, turn off motors” has no effect on raising the pen.  Same with the Manual tab.  Every function on this page works as expected with the exception of the Pen Up / Down functions.  
    Any ideas why the pen would raise and lower without issue ONLY when using toggle pen up/down but not any other mechanism??
    rMBP11,3 – Core i7
    Mac OSX 10.11.4
    Inkscape v0.91r13725
    Eggbot Extension v2.7.1
    EBB Version: EBBv13_and_above EB Firmware Version 2.0.1
    Windell Oskay

    Interesting– I don’t think that I have a ready explanation for what could cause that.

    Do you get the same behavior when running a test print? 

    So I followed the instructions from build to installation to “Hello World”… which is where I got to the point of finding this weirdness:  I couldn’t get the servo to lift in the step to insert the sharpie when I wrote this post.

    I eventually tried to use the “Toggle” to lift the pen, and then manually enabled the motors to start the plot since I couldn’t get the “pen up” to work per the instructions.  The pen never lowered, and the servo stayed activated the entire time.

    That said, I was able to get the “pen up” command to work last night by doing a full shutdown/restart, disconnecting the eggbot from USB & Power and starting clean.  That didn’t conclude the issue however.  If you touch any other settings after lifting the pen, the servo reverts to a non-responsive state, and in some cases simply jittered up and down like a caffeinated kid for no apparent reason (e.g. I was not even in Inkscape – I was looking at your driver code on Github to see if I could call outside of Inkscape, and the servo started bouncing)
    I found the following steps FINALLY worked to get a successful plot:
    1) Connect USB & power
    2) Reset EBB
    3) Start Inkscape
    4) Load SVG
    5) Close blank Inkscape window.
    6) Open EggBot Control
    7) Open Manual tab
    8) Lift Pen
    9) Enable motors
    10) Plot
    At this point the EggBot works normally as expected.  It’s important to note you cannot touch any other settings, or run ANY other manual commands or the pen either will not lift, will stay lifted during the plot, or will jitter constantly.
    I goofed the first time by going in and manually running the egg stepper for 2000 steps to catch a video of the print.  That borked the whole thing and I had to start over because the pen wouldn’t come down again after that – and then began to jitter up and down rapidly.  Once I finally got the servo to quit jittering (took 4 or 5 resets – even persisted a power cycle) I ran thru these steps again and the EggBot was stable for 3 prints.  I gave up around then trying to triangulate the problem since it was about 2am.
    I guess I’m not sure why sending a command to the motors would wreck communication to the servo.  I can’t tell what’s misbehaving really at this point – bad code, bad servo, bad board… I can’t tell.  Sorry I’m usually better at isolating problems.
    Windell Oskay

    It sounds like you may have a bad servo motor. Please contact us directly at customer service, so that we can get a new one sent out to you:


    I wonder if the problem is akin to the one I experienced with the servo:  The servo connector had been manufactured with _way_ too much slop in the sockets that engage the header pins on the EBB.

    This yielded a terminally intermittent servo.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.