Unable to find an AxiDraw

Home Evil Mad Scientist Forums AxiDraw Unable to find an AxiDraw

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #28556
    Pepmore
    Participant

    Hello,
    I just received my Axidraw a few hours ago. Unfortunately I am also getting the “Unable to find an AxiDraw” message. My settings are the following:

    Linux Mint 19.3
    Inkscape 1.0
    I followed the instructions for installing the software and changing the user permissions. I checked and I am in the dialout group. I also checked with the “usb-devices” command and the axidraw is listed as:

    Bus=01 Lev=01 Prnt=01 Port=03 Cnt=03 Dev#= 5 Spd=12 MxCh= 0
    D: Ver= 2.00 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=04d8 ProdID=fd92 Rev=01.82
    S: Manufacturer=SchmalzHaus
    S: Product=EiBotBoard,
    C: #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=100mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
    I: If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm

    I have a mac and I checked there and everything went smooth. I could print without any problem.

    Thanks in advance for the help

    • This topic was modified 10 months, 3 weeks ago by Windell Oskay.
    • This topic was modified 10 months, 3 weeks ago by Windell Oskay.
    #28557
    Pepmore
    Participant

    By the way i forgot to mention that it is the same computer. i just dual boot between mac and linux.

    #28561
    Windell Oskay
    Keymaster

    Can you please say:

    * How you installed Inkscape 1.0
    * Which version of the AxiDraw software you have installed (on the Linux side)
    * The exact text of the error message you are getting

    In any case, I would suggest that you unplug the AxiDraw from both power and USB until the LEDs fade (probably 5-10 s), and then connect _only_ the USB cable (until you have good communication). Wait at least 30 s before trying to access the USB port. This resets the AxiDraw, and allows time for the computer to recognize the newly-connected device.

    You might also try logging out and back in, or rebooting in Linux.

    A possibility is that some kind of permissions issue is preventing Inkscape specifically from accessing your serial port. You might try running Inkscape as root, or try plotting from the CLI to see if that is the case.

    We have seen some cases where distributions do not allow non-root access to USB devices by default, but everything that I see about mint suggests that usually dialout is sufficient ( e.g., https://forums.linuxmint.com/viewtopic.php?t=312551 ).

    #28564
    Pepmore
    Participant

    First I installed the Flatpack 1.0 version. Right now uninstalled it and then installed the normal one from the Ubuntu repository.

    The Axidraw version is: ad_ink1_263

    The error text is:
    Traceback (most recent call last):
    File “axidraw_control.py”, line 7, in <module>
    from lxml import etree
    ModuleNotFoundError: No module named ‘lxml’

    I have run inkscape as root and i got the same message.
    I also tried your unplug recommendation but unfortunately it did not worked. I also log out and reboot my computer several times and it did not worked.

    I will try tomorrow with the CLI

    #28565
    Windell Oskay
    Keymaster

    This is an unrelated error.

    It has to do with whether or not the correct software components are located. It has nothing to do with USB, USB permissions, or so on. It does not make sense to try things like running as root, logging out, rebooting, or unplugging the machine. Those _will not_ address this issue.

    Are other Inkscape extensions working at present? You might try Extensions > Render > Gear > Gear… , for example

    #28566
    Pepmore
    Participant

    Eureka! It is fixed.
    I researched what is lxml and I found out that it is a phython lybrary. I checked in my system and I realized that I did not have it installed. After installing the package phyton3-lxml V 4.2.1-1ubuntu0.1 everything is working correctly. I researched and it seams that it is automatically installed by Inkscape at least in Windows that is why i don’t understand why it was not installed automatically in Linux Mint or why I did not have it installed before in my system. I hope this will help other people having the same problem, as I was.

    By the way the extension Gear is also working now.

    Thanks a lot Windell!!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.